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Storico del documento
15.12.06 V1.0 Creazione del documento

Preambolo e licenza

Questo ¢ un tutorial che presenta i rudimenti d'utilizzazione del software di montaggio Cinelerra,
versione community version. Dopo aver letto questo documento potrete elaborare sequenze video
acquisite con Kino o con Cinelerra, unirle in un video unico, creare delle transizioni tra le scene,
aggiungere un titolo ed utilizzare qualche effetto. Potrete inoltre salvare il vostro video in formato
DVD per l'authoring.

Per l'installazione di Cinelerra ho utilizzato 1 pacchetti .deb su Ubuntu e su Elive. Quest'ultima
(http:/elivecd.org/) € una Debian testing con il wm E17: ¢ esteticamente molto bella, leggera, tutto il

multimedia funziona alla grande ed utilizzando il repository http://www.debian-multimedia.org.

La versione di Cinelerra che utilizzo ¢ in inglese: non so se sia disponibile in italiano. Se esiste e se
volete, adeguate il tutorial e mettetelo in rete.

Per la creazione di questo tutorial ho ampliato ed integrato il documento in francese di Olivier
Hoarau, http://funix.free.fr/informatique/linuxdoc/video/cinelerra.zip, senza il quale non avrei mai

trovato il coraggio.
L'ultima versione di questo tutorial & scaricabile dallURL www.maublog.com seguendo il

collegamento a Cinelerra. Il documento puo essere riprodotto e distribuito liberamente a patto che sia
sempre fatta menzione dell'origine e dell'autore; se avete 1'intenzione di modificarlo o di apportarvi
aggiunte, contattate 1'autore per farne profittare tutti.

Questo documento non puo essere utilizzato commercialmente senza consenso dell'autore, ed & fornito

“com'e”, senza garanzia di alcun genere: I'autore non puo essere ritenuto responsabile di qualunque
danno che possa derivare dalle tecniche descritte in questo documento.



Configurazione di Cinelerra

Dopo aver installato e lanciato Cinelerra, ci apparira questa schermata:

Cinelerra: Compositor

Cinelerra: Viewer
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Welcome to Cinelerra. o e

Possiamo chiudere tutte le finestre, mantenendo aperta solo la finestra Program: le finestre chiuse
potranno essere riaperte dal ment Window.

Cinelerra ¢ soggetto a qualche crash: per fortuna, salva il vostro progetto ogni volta che viene
modificato, per cui basta, dopo averlo riaperto, andare come prima cosa sul menu File —> Load
Backup per ritrovare il vostro lavoro 1a dove s'era interrotto. Ciononostante, salvate frequentemente il
vostro lavoro (menu File —> Save, oppure digitando “s”). Dovete sapere che, salvando un progetto,
Cinelerra salva solo le informazioni che riguardano i file audio e video utilizzati, che quindi non
vengono modificati: voi non dovete far altro che lasciarli nella cartella/directory dove sono finché il
progetto non ¢ definitivamente chiuso.



Adesso configuriamo Cinelerra per stabilire il formato del file video in uscita: dobbiamo conoscere 1

parametri del video in entrata, per evitare, ad esempio, di definire in uscita un frame rate non

compatibile. Accediamo a questi parametri attraverso il menu Settings —> Format (Shift + f).

w

Presets:
User Defined

Audio

Samplerate:
Samplerate: 48000

Channels: 2

Channel positions:

Video

Frame rate: 250000

Canvas size:
Width: 770 i I

Height: 576
W Ratio: 1.0000

H Ratio: 1.33323

Color model: RGBABRIt |}

Aspect ratio:

4.0000 30000 |} Auto

Interlace mode Bottom Fields First| J

Apply Cancel

Impostiamo frequenza e formato dimmagine (Width ed Height, fissando poi 1'Aspect Ratio a 4:3 o

16:9). Gli altri parametri possono essere lasciat ai valori prestabiliti.



Nel menu Settings —> Preferences (Shift + p) possiamo definire i parametri di cattura del segnale. Con
una periferica IEEE (o 1394, o Firewire) le impostazioni sono queste:

m

Playback Recording Performance Interface About

File Format:

File Format: Quicktime for Linux

2 Record audio tracks

N Record video tracks

Audio In

Record Driver: Device: Bits:
ALSA —
default 4 16 Bit Linear 4

Samples to write to disk at atime: 131072

Sample rate for recording: 48000 4

Channels to record: )

Record in realtime priority {root only)

Video In

Record Driver: . . Device path:
VideodLinux
fdevivideoO

Frames to record to disk at atime: 925
Frames to buffer in device: 2
Use software for positioning information
Syne drives automatically
Size of captured frame: 729

Frame rate for recording: 25

Import images with a duration of 5 ygqg Seconds

Utilizzando le due distribuzioni citate nel preambolo non ho dovuto effettuare collegamenti simbolici
o altro.



Ecco ora la configurazione per la lettura dei file video (sempre menu Settings —> Preferences, oppure
Shift + p).

Playback Recording Performance Interface

Audio Out
Playback buffer size: 16384
Audio offset {sec¢): g.0000

Yiew follows playback

Use software for positioning information

Audio playback in real time priority (root only)

Audio Driver: 055 Device path: Bits:
fdevidsp 16 Bit Linear

Video Out

Play every frame Framerate achieved:
Decode frames asynchronously

Scaling equation:

Mearest neighbor enlarge and reduce
Bicubic enlarge and bilinear reduce
Bilinear enlarge and bilinear reduce

Preload buffer for Quicktime:

DVD Subtitle to display: Enable subtitles
Interpolate CR2 images
White balance CR2 images

0 0 0

Video Diriver: = Display for compositor:




Acquisizione

Acquisizione con Kino

Possiamo acquisire il video dalla sorgente con Kino. Salviamo il tutto in formato QuicktimeDV, come
indicato nello screenshot qui sotto. Attenzione, per acquisire in QuicktimeDV il supporto dev'essere
compilato all'atto dell'installazione, cosa che io non ho fatto :-) : nela caso, vi apparira, sotto RawDV,
la voce QuicktimeDV

Defaults | Cattura | IEEE 1394 | Display | Audio | Jog/Shuttle | Altre

Specifica il nome del file di uscita senza estensione

File | capture | B
Tipo di File Altre Opzioni per i File
1 DV AV Tipo 1 [+] Dividi Automaticamente i Files
() DV AVI Tipo 2 [] Metti Data/Ora nel Nome del File
[1 OpenDML AVI Scrivi Ogni: |1 | Fotogramma
Quadri per File: |7000 |
@) Raw DV 3 :
Mag. Dimensione del File: |2000 | MB
(entrambi O = illimitato)
’ (] aiuto ’ . ¥ Annulla ’ &P ox ’

Possiamo acquisire anche con dvgrab, salvando in QuicktimeDV.

Con l'acquisizione si ottiene un file .mov. Con il comando qtinfo otteniamo delle informazioni che

saranno utili nella configurazione di Cinelerra. Un piccolo esempio: digitando
qtinfo video.mov
otteniamo

File video.mov:
1 audio tracks

2 channels, 16 bits, sample rate 32000, length xxxx samples, compressor twos.



supported.

1 video tracks.
720x576, depth 24, rate 25.000000, length xxxx frames, compressor dvc.
supported.

da cui possiamo leggere che il nostro file video.mov, ottenuto con Kino, presenta un formato
immagine 720x576 pixel, e che il frame rate ¢ di 25 fotogrammi/sec.

Acquisizione con Cinelerra

Per acquisire da una sorgente basta cliccare su File -> Record (o sul tasto r). Appaiono due finestre: in
quella di sinistra troviamo anche i comandi di trascinamento per 1'eventuale videocamera collegata. La
finestra di destra ci permette di visualizzare in tempo reale cid che viene registrato: per non perdere
fotogrammi in caso di macchina poco potente, disattivare Monitor video o Monitor audio nella
finestra di sinistra.

Cinelerra: Video in

Path: Format: Quicktime for Linuxf| ~"2""¢!

Audio compression: 16 Bit Linear
Samplerate: 48000

Clipped samples:

Source: Video compression: Component Y'ChC
Mode: Untimed Framerate: 25.00

Frames behind:

Position:

Prev label:

Start time: Sun |4 00:00:00
Duration time: 0-:00:00

Transport: M ] m

Batches: Activate Start Delete New Label
Fill frames Monitor video Monitor audio

(.~ Path News Start time Duration Source

Insertion strategy:

Paste at insertion point




Quando la registrazione ¢ terminata si puo scegliere come strategia d'inserzione “Replace current
project” per creare un nuovo progetto. Le scene acquisite appariranno automaticamente:

Cinelerra: Viewer : Cinelerra: Compositor
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I N 000 |0 0:00:10.00
Video 1 | | davide.avi #1 / m
8 o4 »r — /| fee Media =]
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Welcome to Cineleri‘a. ﬁ_‘j{,, NE E ; e 'i‘
Ora possiamo importare altre sequenze acquisite con Kino che vogliamo includere nel progetto (menu
File -> Load files):

Select files to load:
fhome/babbotvideo/

File v Size Date
aperi.avi 103929042 Mar 21, 2006
davide.avi 43205726 Oct 29, 2006
saria.avi 96450830 Mar 21, 2006
titolo.png 23011 Mov 18, 2006

davide.avi

=

Insertion strategy:

Concatenate to existing tracks




Possiamo anche selezionare in un sol colpo tutti i file che ci interessano (a condizione che si trovino
nella stessa directory). Come strategia d'inserzione scegliamo “Concatenate to existing tracks” e ci
troveremo in ordine tutti i files acquisiti.

Passiamo ora a salvare il nostro progetto (menu File -> Save, oppure tasto “s”).
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Montaggio

Ora possiamo passare al montaggio vero e proprio. Se abbiamo chiuso tutte le finestre eccetto
Program, riapriamo le finestre Resources, Compositor e Viewer:

menu Window -> Show Resources,
menu Window -> Show Compositor,
menu Window -> Show Viewer

N N

Audio Effects Clips

)

| Video Effects Media

N

Audio Transitions

N

Video Transitions
)

Labels

saria.avi

[ B o o = S S == R
Md<ddmDdpPmwM

Nello screenshot qui sopra, a sinistra la finestra Resources, a destra la finestra Viewer. Nella finestra
Resources si trovano tutte le risorse del progetto, i file video nella cartella Media, le transizioni video
in un'altra cartella, ecc. Nella cartella Media, selezionata per default, vediamo i file video prima
acquisiti o caricati: con il drag 'n' drop li trasciniamo nella finestra Viewer (o anche clicchiamo destro
-> view) per visualizzari.

Ora da questo insieme di sequenze video estraiamo le sequenze che preferiamo, o piuttosto andiamo a
togliere quelle che non ci piacciono.

Nella finestra Compositor, aiutandoci con il cursore del tempo (nella finestra Program, cliccando al
livello della scala dei tempi), ci spostiamo tra le differenti scene.
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Per selezionare le scene indesiderate:

nella finestra Compositor andiamo all'inizio della sequenza da eliminare e clicchiamo sull'icona [, poi
e,

andiamo alla fine della sequenza e clicchiamo sull'icona ]; indi o premiamo il tasto “x” o menu Edit
-> Cut

oppure:
nella finestra Program passiamo in modalita “Cut and Paste” (cliccando sull'icona | - che si colora
d'arancio), selezioniamo la sequenza voluta, poi la eliminiamo digitando “x” o con menu Edit -> Cut.

Ripetiamo per tutte le scene indesiderate.

Per vedere il risultato della nostra fatica, clicchiamo la quinta icona da destra della finestra Program
“Fit selection to display” (oppure digitiamo il tasto “f”).

Ora che abbiamo le scene che c'interessano, possiamo sistemarle nell'ordine che preferiamo. Andiamo
in modalita “Drag 'n' Drop” (cliccando sull'icona a forma di freccia nella finestra Program, che si
colora d'arancio). Nella finestra Program, con il drag and drop si possono trascinare e riordinare le

scene come vogliamo.

Passiamo adesso alle transizioni tra due scene: nella finestra Resources c'e¢ una cartella Video
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Transitions che contiene un certo numero di transizioni:

e,
Audio Effects Clips A‘-

%ﬂ" BandSlide IrisSquare
|

-. :
- ; = ]
Video Effects Media !

BandWipe Shape Wipe
Audio Transitions 4
P

Video Transitions Dissolve Slide

E
Labels

Flash Wipe

Scegliamo quella che vogliamo (10 ho utilizzato Iris Square) e la trasciniamo nella finestra Program
tra due scene. Appare l'icona della transizione e, cliccandovi sopra con il tasto destro del mouse,
compare il menu sottostante:

File Edit Keyframes Audio Video Tracks Settings View Window
“«A4dmDPPrHPMH [ KAIG@ | CITXBRSEE
Q:00:08.980 10:00:00.000 10:00:05.000 ]0:00:10.0(‘“
Video 1 e saria.avi #1 davide.avi #1
8 @« )

I;-.Show
| « On
| Length: 0.52 sec
| Detach

Audio 1 . saria.avi #1
B @ g »

Audio 2 | _saria.avi #2_ davide.avi #2
8 @9 »

w

00021461 ¥ A 64 Audio Fade: ¥ 4 .80.0 to 6.0

Welcome to Cinelerra. 0%

Per variare la durata della transizione dobbiamo cliccare su Length, mentre cliccare su Detach avra
I'effetto di cancellare la transizione stessa.
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Adesso possiamo visualizzare il nostro lavoro cliccando sul bottone Play della finestra Program: il
risultato apparira nella finestra Compositor (lo screenshot seguente ¢ stato acquisito nel mezzo della
transizione IrisSquare)
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#
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C I Xbhelioesge o216 &
4 m D M Auto v

Aggiungiamo ora un titolo al nostro video: bisogna comunque tener presente che la funzionalita della
titolatrice ¢ molto limitata, e che conviene piu creare il titolo in Gimp con sfondo trasparente (io ho
utilizzato i formati .png e .tga) ed inserirlo nel nostro progetto su un'ulteriore traccia video (Video ->
Add track oppure Shift+t). Se vogliamo comunque utilizzare il plugin di Cinelerra, nella cartella
“Video Effects” della finestra Resources scegliamo “Title”, lo trasciniamo all'inizio della sequenza su
cui dovra comparire, nella finestra Program e ne regoliamo la lunghezza: successivamente, cliccando
destro sulla traccia rossa, ne applichiamo il testo, il font, il colore, la presenza o meno dell'ombra, la
posizione, il tipo di scorrimento e quant'altro vogliamo.

File Edit Keyframes Audio Video Tracks Settings View Window i_\‘
[ 4 m D M I & LI XBhROEHI ST X
‘0:00:00‘()00 ‘0:()0"0,000 ‘(]:00:2().()00 0:00:30.000 ‘0:()0:40

\udio Effects Clips

N
Video 1 saria.avi #1 | davide.avi #1 > ‘

8 ¢4 v _—‘—_——‘— ideo Effects Media

aperi.avi

R 0.0000 § i . ¥ Audio Transitions m
7 "y

Audio 1 aria.e vide. aperi.avi #1
B9 <4 > Baal sl tloh ek 0w . Video Transitions

saria.avi

0:00:42922 v S ) 6 Audio Fade: < 80.0t06.0

Welcome to Cinelerra. % ey

Una striscia rossa appare per tutta la durata della sequenza interessata, il che significa che il titolo
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apparira per il tempo corrispondente: non ¢ proprio quello che vogliamo, per cui bastera selezionare la
fine della striscia rossa e poi ridurla. Ora cliccando destro col mouse sulla striscia rossa appare un
menu, e cliccando su Show possiamo configurare il nostro titolo, come nell'immagine sottostante:

Font: Size: Style: Justify:
4 + 24 J Italic Left Top

w

fixed
X: Y: kMotion type: Bold Center kid

Y \ -
0 s 0 ¥ Mo motion J Loop Right Bottom

Drop shadow: Fade in (sec): Fade out (sec): Speed:
10 < 0.0000 0.0000 1.0000

Encoding:
1508859-1 1

Text: Stamp timecode Format: h:mm:ss:ff

Infine passiamo ad esportare il nostro prodotto, nel formato Quicktime for Linux, dalla finestra

Program, menu File -> Render (Shift+r)

Select a file to render to:

video.mov

File Format: Quicktime for Linux

LY Render audio tracks

L. Render video tracks

Create new file at each label

Insertion strategy:
Append in new tracks

ATTENZIONE: Quicktime for Linux, se non si applica compressione, occupa circa 17 Mb al secondo.
Al termine, se il comp e I'hard disk sono abbastanza veloci, possiamo visualizzare il risultato con

qualsiasi lettore (mplayer, xine, ecc.).
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Gli effetti

Certo non li ho messi tutti, ma penso che valga per tutti il consiglio di provare tenendo, come ho fatto
i0, “Secrets of Cinelerra” su un altro schermo. Per alcuni di quelli che ho usato, come Motion e
ReframeRT, ho trovato proficuo effettuare una prima renderizzazione in un formato lossless,
reimportando il risultato nel progetto finale.
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Il Motion Tracker

Nella cartella “Video Effects” abbiamo a nostra disposizione una gran quantita di effetti video, tra cui
troviamo “Motion”, che ¢ simile al motion tracker di After Effects e funziona abbastanza bene per i
nostri scopi amatoriali: posso sbagliarmi, ma l'importante ¢ deinterallacciareil file sorgente.

Il motion tracker ¢, di per se, un'intera applicazione, che traccia due tipi di moto: traslazione e
rotazione, insieme o separatamente. Puo fare tracking di % di pixel o di un pixel. Puo stabilizzare il
movimento o far seguire ad una traccia il moto di un'altra traccia.

Sebbene sia applicato come effetto realtime, normalmente, per vedere qualche risultato utile,
dev'essere renderizzato. L'applicazione impiega parecchio tempo per individuare con precisione il
moto.

Il motion tracker lavora usando una zona del fotogramma come regione da tracciare, e paragona
questa regione tra due fotogrammi per calcolare il movimento. Questa regione puo essere definita in
qualunque zona dello schermo. Una volta calcolato il moto tra i due fotogrammi, con il parametro
ottenuto si puod fare un certo numero di cose: puo essere scalato per un coefficiente arbitrario ed
ancorato ad un valore massimo, gettato via o aggiunto a tutti i valori che hanno portato alla posizione
attuale. Per risparmiare tempo, il risultato del movimento puo essere salvato per utilizzarlo piu tardi,
richiamarlo da un calcolo precedenteo lasciarlo inutilizzato.

Il motion tracker puo agire su 2 tracce, il livello master ed il livello target. Il livello master ¢ dove ha
luogo la comparazione tra due fotogrammi. Il livello target & quello al quale viene applicato il
movimento per tracciare o compensare il movimento del livello master.

Le complicazioni del motion tracking sono abbastanza da sostenere intere societa e costruirvi intorno
delle carriere. Il motion tracking di Cinelerra non ¢ sofisticato quanto i tracking di livello mondiale
ma lo ¢ comunque abbastanza da addolcire il movimento delle sequenze della vostra videocamera.
Qualche suggerimento che vi semplifichera la vita:

e prima del motion tracking viene applicato quasi sempre un istogramma per rimuovere il
rumore dei pixel piu scuri. O salvate i vettori di moto nel primo passaggio e disabilitate
l'istogramma per il passaggio attivo, oppure applicate l'istogramma solo al livello master.

e con sequenze estremamente rumorose o interallacciate, 1'applicare un effetto blur prima del
motion tracking puo migliorare I'accuratezza del tracciamento: anche in questo caso, o salvate
1 vettori di moto nel primo passaggio e disabilitate il blur per il passaggio attivo, oppure
applicate il blur solo al livello master.

Allora, cominciamo a provare. Prendete quella sequenza che non avete mai utilizzato perché
tremolante e mossa, trascinatela nella timeline ed applicatevi 1'effetto Motion, dopodiché cliccate
sull'icona a forma di lente dingrandimento sulla barra dell'effetto oppure cliccate destro e poi su
“Show”. Vi apparira la finestra sottostante, nella quale non ¢ molto difficile orizzontarsi, sapendo pit
o meno di cosa si parla: ovviamente non guardate i valori che trovate riportati nell'immagine sotto
riportata, i vostri saranno certamente diversi!
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Track translation Track rotation

Translation search radius: <= < Rotation search radius:
(WWH Percent of image) iDegrees)

Translation block size: < ) Rotation block size:
(WWH Percent of image) T (WH Percent of image)

Translation search steps: 256 v Rotation search steps:

Translation direction: Both

Block X: [ ° 41.4000

Block Y: ™ = 241000

Maximum absolute offset: [—

Settling speed:
Draw vectors
Track single frame Frame number: g

Track previous frame
Previous frame same block

kaster layer: Bottom v
Action: Track Pixel ¥

Calculation: Load coords from /tmp ¥

Bene, adesso tornate al primo fotogramma della sequenza da stabilizzare. Assicuratevi che sia
spuntata la voce “Draw vectors” e che le voci “Action” e “Calculation” siano impostate a “Do
nothing” e “Don't Calculate”. Ora guardate la finestra Compositor: vedrete due piccoli rettangoli 1'uno
nell'altro. Il rettangolo interno (quello che al centro ha un puntino) ¢ quello con il quale — con l'aiuto
dei controlli Block X e Block Y — andrete a “centrare” 1'oggetto che sara il riferimento per il tracking.
Per 1'oggetto di riferimento sceglietene uno abbastanza contrastato e dai contorni netti. Una volta che
l'avrete “centrato”, con l'aiuto dei due controlli “Translation block size” dovrete adeguare il rettangolo
interno alle dimensioni dell'oggetto scelto come riferimento. I due controlli “Translation search
radius”, invece, vi serviranno per dimensionare il rettangolo esterno cosicché, per l'intera durata della
sequenza da stabilizzare, 'oggetto tracciato risulti sempre contenuto nello stesso rettangolo esterno.
Adesso impostate le voci “Action” a “Track Pixel” e “Calculation” a “Save coords to /temp”. Pronti?
Fate qualche prova per controllare se ¢ tutto a posto, se la freccetta che vedrete comparire dentro al
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rettangolo piu interno indica sempre l'oggetto da tracciare, se non ci sono scatti improvvisi nella
sequenza, insomma se tutto va per il verso giusto: se c'¢ qualche anomalia, divertitevi pure a trovarne
il motivo (avete provato ad applicare I'istogramma e/0 il blur, come vi ho suggerito all'inizio?).

Dopo aver effettuato una prima pseudo-rendernizzazione, in cui il programma scrivera su di un file
temporaneo 1 dati che gli serviranno per la successiva stabilizzazione, passate alla renderizzazione:

1) togliete la spunta da Draw vectors;

2) se avete applicato Blur e/o istogramma, disattivateli;

3) in Action impostate “Stabilize pixel”;

4) 1n Calculation impostate ‘“Load coords from /temp”;

5) digitate Shift+r (oppure menu File -> Render) e salvate come .mov: ci vorra un po' di tempo,
in dipendenza come al solito della velocita del sistema, della lunghezza della sequenza, di
eventuali altri effetti, e cosi via...

Quando avrete il vostro file stabilizzato a disposizione, vi accorgerete che 1'oggetto voluto sara rimasto
approssimativamente fermo, ma che sara la sequenza ad ondeggiare, ovviamente. A questo punto,
dovrete decidere, sempre provando, se ¢ meglio perdere in nitidezza apparente, applicando alla
sequenza l'effetto “Scale” in modo da far restare I'immagine sempre nel visibile, oppure vignettare la
sequenza con una maschera (sempre all'interno di Cinelerra), oppure lasciar perdere tutto ed
andarvene al bar con gli amici (a volte ne viene voglia).

L'effetto “Motion” da' anche possibilita di tracciare la rotazione di un oggetto, di applicare i dati della
tracciatura ad un altro livello o di applicare altri parametri: non ho provato né le une né gli altri, ma

credo che con l'aiuto di “Secrets of Cinelerra” si possano capire tutti.
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L'effetto ReframeRT

Questo ¢ facile, utile e funziona bene: serve a rallentare o velocizzare una clip portandola alla
lunghezza che si vuole. A me ¢ quasi sempre utile per rallentare, e quindi allungare, una clip troppo
breve. Ha due sole modalita di funzionamento, Stretch e Downsample.

e Stretch varia la durata della clip mantenendo inalterato il frame rate,
e Downsample varia il frame rate mantenendo inalterata la durata della clip.

Per ambedue le modalita il coefficiente di variazione (Scale by amount) se maggiore di zero aumenta
la velocita, se minore la riduce. Da tener presente che, una volta selezionata la clip da trattare, lunga
ad esempio 47, per portarla ad 8” dovremo applicare I'effetto con modalita Stretch e Scale by amount
di 0.5000 (cioe rapporto 1:2), poi, sulla timeline, agire solo sulla lunghezza della barra dell'effetto in
maniera da farle coprire 8 secondi. Ripeto, la clip deve restare di 4” e bisogna allungare solo la barra
dell'effetto! Se vogliamo invece portarla a 16”, lo Scale by amount dovra essere di 0.2500 (cioe

rapporto 1:4) e la barra dell'effetto dovra essere allungata a 16”: ovvio che il movimento non sara cosi
fluido.
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L'effetto Reframe

Se avete bisogno solo di allungare una clip troppo corta e vi volete semplificare la vita, potete evitare
in maniera semplice tutto I'ambaradan di cui sopra: evidenziate la clip che vi interessa (doppio clic
sulla barra del nome) e andate a menu Video -> Render effect -> Reframe (senza RT), applicate il
coefficiente di velocita voluto, scegliete un nome file, et voila, il gioco ¢ fatto.
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Esportazione per il DVD

Per 1'esportazione del nostro prodotto per 1'authoring, riporto la procedura che mi ha dato 1 migliori
risultati: ¢ tratta da un tutorial brasiliano della “estudio livre — punto de cultura” (grazie! :-)).

Per renderizzare il vostro capolavoro, menu File -> Render (Shift+r). E preferibile che i due file
risultanti, audio e video, si trovino nella stessa directory: non ¢ obbligatorio, ma rendera piu agevole la
generazione del file nell'ultimo passo.

Renderizziamo l'audio: da "File Format" scegliete "Microsoft WAV"; date un nome al file che state
per creare, con estensione .wav, togliete la spunta da “Video”, disabilitando cosi la traccia video, e
spuntate la casella "Audio", abilitando cosi la renderizzazione della colonna sonora. Cliccate
sull'icona a forma di chiave inglese a fianco a “Audio” e sul riquadro che appare scegliamo come
compressione ‘“Twos complement”, 16 bit per canale. Togliete, se c'¢, il segno di spunta da “Dither”.
Avviate la renderizzazione, che dovrebbe impiegare pochi secondi.

Ora renderizziamo il video: in "File Format" scegliete "YUV4MPEG Stream"; date un nome al file
che state per creare, con estensione .m2v, togliete la spunta da “Audio”, disabilitando cosi la traccia
audio, e spuntate la casella "Video", abilitando cosi la renderizzazione della traccia video. Cliccate
sull'icona a forma di chiave inglese a fianco a “Video”, sul riquadro che appare spuntate la voce “Use
Pipe” e su “Pipe Presets” clicchiate su ffmpeg. A questo punto, a seconda della versione di Cinelerra
installata o compilata, troverete, a fianco di “Use Pipe”, una delle due versioni della pipe per DVD di
ffmpeg:

ffmpeg -f yuvdmpegpipe -i - -y - target dvd % oppure
ffmpeg -f yuvdmpegpipe -i - -y -target dvd -ilme -ildct -hq -f mpeg2video %

in questa seconda ipotesi, dovrete rimuovere 1'opzione -hq in quanto non supportata da ffmpeg e che,
se utilizzata, causa errore.

Alla fine di tutta la procedura, potrete ricombinare (muxare) audio e video da terminale in un unico
file con ffmpeg:
ffmpeg -i audio.wav -i video.m2v -target dvd risultato.mpg

FINE
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